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Overview

The purpose of this document is to provide a step-by-step guide to using the User Defined Models tab,
which is located in the Options menu of the Transient Stability Add On in PowerWorld Simulator. The
user defined model feature has been made available from version 17 onward. This tutorial aims to
provide the basic steps for navigating the tabs of interest, loading, inserting, and using user defined
models for transient analysis. Section 0 is geared towards basic users, and section 3 will provide a brief

note for advanced developers.

1. Before you begin...

Download the sample files and projects from the PowerWorld website. The content is shown below.

- pl@m e

, < Desktop » BasicUser »

Mame =
= CppDLLs
Cpp_GEMCLSUDM.dII
Cpp_IEEESTUDM.dII
Cpp_IEEETIUDM.dII
Cpp_TGOVIUDM.dII
= FtnDLLs
Ftn_GEMCLSUDM.JII
Ftn_IEEESTUDM.dII
Ftn_IEEET1LIDM.dII
Ftn_TGOVIUDM.dII
= ObjPsIDLLs
ObjPsl_GEMCLSUDM.dII
ObjPsI_[EEESTUDM.dII
ObjPsI_[EEETIUDM.dII
ObjP=l_TGOVIUDM.dII
= TestCases
®| WSCC_9_withMNoDLLs.pwhb

The BasicUser folder contains four folders. The
folders CppDLLs, FtnDLLs and ObjPsIDLLs have
identical DLLs of the GENCLS machine, IEEEST
stabilizer, IEEET1 exciter and TGOV1 governor.
In addition, the TestCases folder contains a case
for illustrating the use of these DLLs.

Corresponding to the DLLs from the BasicUser
folder, the AdvancedDeveloper folder contains
various subfolders containing the source code
for generating the respective DLLs. The project
structure of Cpp IEEET1IUDM is shown on the
right-side of this page.
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Mame =

Exciter
C++

= Debug

Cpp_IEEETIUDM.dII
| Cpp_IEEET1UDM.exp
=2 Cpp_IEEETIUDM.ilk
34 Cpp_IEEET1UDM.lib
¥| Cpp_IEEETIUDM.pdb

= IEEETIUDM

Debug
¢+ IEEET1DIL.cpp
=] IEEET1DIIdef
] IEEET1DILh
7 IEEET1UDM.vexproj
7 IEEETIUDM.vexproj filters
% IEEET1UDM.vexproj.user
 IEEET1UDM.sdf
% IEEET1UDM.sIn
5 [EEET1UDM.suo
Delphi
FTNG5
Governor
C++
Delphi
FTNG5
Machine
C++
Delphi
FTNAS
Stabilizer
C++
Delphi
FTNG5



2. Basic Users

It is likely that a basic user will receive a set of DLL files, each with one transient model of interest. (The
development of these DLLs is left to the advanced developer.) This section will outline the steps in
PowerWorld Simulator for loading, inserting and using user defined models.

1. Start PowerWorld Simulator, and navigate to File > Open Case...

Simulator 18

vl'_‘l MNew Case Recent Cases Case Des
o5 Open Case... 1WSCC_9_withNoDLLs Case Sum
Open Simulation Case [Ctri=0) 10DLLs ‘ Custom C

¥ 3WSCC_9_withAllDLLs Case

ble Transfer
- 1 QV Curves
ose Oneline =nt Stability

2. Navigate to BasicUser > TestCases folder. Select the WSCC_9_withNoDLLs.pwb file, and click Open.

IR » bosctser » Tescoes -4

Views = BB New Folder &)

Date modified Type

WSCC 9_withMoDLLs.pwh
PWE File
214 KB

File name: WSCC_3_withNoDLLs pwb - [inerWand Binary {* pwh) vl

[ Open IV] [ Cancel ]




3. Once the case loads, navigate to the Case Information tab. In Model Explorer, navigate to the
Transient Stability > Summary > Generator model use option in the left-side menu.

B Model Explorer: Generator Model Use - Case: WSCC_9_withNoDLLs.pwb Status: Initialized | Simulator
GIEM  case information Tools  Options  AddOns  Window
R — & ? Network ~ —t @[]  Case Description..  Power Flow List o iz
3 i o b
ggregation - AX @ Case Summary.. Quick Power Flow List... =il i bl
[RunMode| ~ Model  Ares/zone i i Difference  Simulator Bus Oneline Open
— Explorer..  Filters.. Monitoring..  =olution Details - Flows~  Optons.. tMstomCaselnfo..  AUXExport Format Desc. View.. Viewer..  Windows -
Mode | Case Information | Case Data | Views |
Explore & || Generator Model Summary |
Explore | Fields P B Al tR 5% dh 98, °F Records - Geo - Set- Columns - o WA ¥ BH- W fix - B | options -
> [ Recent .
b [ Network i Filter Aﬂvaﬂ(ﬁ#' Generator |' ~ |Find.. Remove Quick Filter...
> [ Aggregations Number of | & |Name of Bus|ID|Status | Gen Mw|MvA BasglMachine |Exciter |Governor|StabiizeMOther Model|Governor | StepR | Step X [Step Tap|R (internal [x (internal
> [ Solution Details Response Resistance) [Reactance)
» [ Case Information and Ausdiary Limits
> [ Optimal Power Flow 1 TlBus1 1 Closed 7164 50 ENROU [EEETL Normal  0.00000 0.00000 1.0000  0.00000  0.18000
» 4 Tools and Add Ons 2| 2 Bus 2 1 Closed 163.00 2 ENCLS Mormal  0.00000 00D 10000 0.00000  0.20000
4 3 Transient Stabilty 3] 3Bus3 1 Closed 85.00 Normal  0.00000 ©0.00000 10000 0.00000  ©0.13000
» [ DC Models
4 [ Summary
4 Generator Model Use
4 Load Model Use
HH Model Support Status
4 Models in Use

Machine [Exciter |Governor|Stabilizer

GEMROU IEEET1
GEMCLS
(GEMR.OU IEEET1 TGOV1  IEEEST

In the Generator Model Summary tab the machine, exciter, governor and stabilizer models in use
are displayed. These models are built-in models supported by PowerWorld Simulator. In the
subsequent steps, user defined models will be inserted to replace these models.

Ensure that Simulator is in Run Mode. Navigate to the Transient Stability in the Add Ons tab. In the

left-side menu, click on Options > User Defined Models. This is currently empty because no user
defined models have been selected/inserted.

0t~ "REEF 3

Transient Stability Analysis - Case: WSCC_9_withNoDLLs.pwb Status: Initialized | Simulator

File Tools Options Add Ons Window

. (%) Abort q ~ gf o E&
Edit Mode 5 1og Brimal LP ﬁ m D Refine Model | W %
— V.. Q L

Run Mod SCOPF..  OPFCase  OPF Options P
[un haose B script -

V.. C. Transient  Stability GIC...
Info+  and Results Stability.. Case Info~
Mode | Log | Optimal Power Flow (OPF) | Pvand@veurves(Pvay) | ATC | TransientStability(TS) | GIC | Schedule |
Simulation Status Mot Initialized
Run Transient Stabilty | | Pause | | abort | | Restore Reference | For Contingency: [UDM_COMBINED_DEMO -
Select Step Options |
4 'g’“:‘a"'““ Note: Changes made to option entries are saved immediately and will be applied during the next transient stability run.
4 Options
General General | Power System Model | Result Options | Generic Limit Monitars | User Defined Models | Distributed Computing |
- Power System Model Ordered list of paths for finding User Defined Model DLLs
Result Options Click on button below to define a browsing path
~Generic Linit Monitors Place User Defined Model DLLs in
User Defined Madels these directories where they will be
Distributed Computing automatically detected
- -Result Storage
> Plots Edit Browsing Path
- -Results from RAM e o a0
o & e COEE- - WL OB U oy - .
 Transient Linit Monitors ] B ok %8 % dh 99 | Records - Set~ Columns B2~ . B W0 f - B | options
» States/Manual Control User Defined Models Al
1> - Validation HH Al
SMIS Eigenvalues 1 UserDefinedExciter ‘Ubject Type|Device Status|sub-Intervals[Model Name|DLL valid gﬂ'\er Object
(3 UserDefined =1
(1 UserDefinedLoadMa! Defin
[ UserDefinedMachine
(3 UserDefinedMTDCC:
[ UserDefinedMultTer
(3 UserDefinedstabiize

5. Click on the Edit Browsing Path button.



6. Inthe window below, click Browse.

Edit Browsing Path i . 5 =

Ordered list of paths for finding User Defined Model DLLs

Browse

Replace Add Delete Delete Invalid Paths

Lok | | X cancel|

7. Then, browse for the BasicUser > CppDLLs folder. Click OK.

Browse for a folder

[ . AdvancedDeveloper
4 | BasicUser

. CppDLLs

. FtnDLLs

. ObjPsIDLLs

| TestCases

Folder:  CppDLLs

Make Mew Folder ]

8. Click Add. The path name should appear in the list. Then, click OK.

I
[®) Edit Browsing Path @@J o B R

Ordered list of paths for finding User Defined Model DLLs

Ci\Jsersisaurav\Desktop BasicUser \CppDLLs Browse
Repiace | [ add ] | pelete | | Deletemaidpats |

o< | [ Xl |




9. Simulator scans the folder in the browsing path(s), and automatically loads and validates the DLLs.
They are also categorized based on their model types. In this case, four DLLs are shown to have been

loaded.

| General I Power System Model | Result Options | Generic Limit Monitors | User Defined Models |Distributed Computing|
QOrdered list of paths for finding User Defined Model DLLs
Ci\Users\saurav\Desktop\BasicUser\CppDLLs

Place User Defined Model DLLs in
these directories where they will be
automatically detected

[ Edit Browsing Path |

] B Ak %8 8 | @ 43, | Records - Set~ columns - [~ @2~ WA~ ER- § fx - B | Options -
User Defined Models Al |
= al
4 [ UserDefinedExciter Object|Type|Device Status|Sub-Intervals|Model Name [DLL Valid|Other Object
] Cpp_IEEET1UDM .
one_|Defin

4 [ UserDefinedGovernor
] cpp_TeoviUDM
1 UserDefinedLoadModel
4 [ UserDefinedMachineMadel
HH Cpp_GEMCLSUDM
3 UserDefinedMTDCConverter
3 UserDefinedMultiTerminalDC
4 [ UserDefinedStabilizer
HH Cpp_IEEESTUDM

10. Click on Cpp_IEEET1DM, and the following description should appear in the lower pane of this tab.
This shows the DLL Functions’ Names, Extra Objects Types, Default Parameter Values, States
Description, Hard-Coded Signals Variable and Algebraic Variable Description. There should be no
error message shown, and the dll should be ready for use. At this point, the user defined model is
recognized by Simulator can be handled just like any built-in model.

DLL Location  C:\Users\saurav\Desktop'\BasicUser \CppDLLs\Cpp_IEEET 1UDM.dI

Maodel Type  UserDefinedExdter Model Mame Cpp_IEEET 1UDM

DLL Functions Extra Objects Parameters States Hard-Coded Signals Algebraics
MNames Type (Description) |Mame [Default] |Description |Variable [Description] Variable [Description]
Implemented Functions 0 Tr [i] 0: EField 0: Vref (Voltage Reference)
modelClassMame 1: Ka [50] 1: Sensed Vt|1: Initial Efield
DLLYersion 2: Ta [0.04] 21 VR 2: Field Current
parameterflame 3 Vrmax [1] 3 WF 3: Voltage Compensated
stateMame 4 Vrmin [-1] 4: Generator Speed Deviation (pu)
allParamCounts 5: Ke [0.08] 5: Voltage Generator Terminal
getDefaultParameterValue & Te [0.06] 6: Stabilizer Input (Vs)
SubIntervalPower 2Exponent 7 Kf [0.09] 7: Flag for active OEL (1 if active)
initializeYourself & T [1.46] 8: Qver Exdtation Limiter Signal
getMon\WindUpLimits 9 Switch [0] 9: Flag for active UEL (1if active)
calculateFofy 10: E1 [2.8] 10: Under Excitation Limiter Signal
PropagatelgnoredstateAndInput 11: SE(EL) [0.04]
ExdterEfieldOut 12: E2 [3.73]
Optional Functions Omitted 13: SE(EZ) [0.33]
OtherObjectClass 14: Spdmlt [0]
OtherObjectDescription
signalselection
getstringParambefaultvalue
TimeStepEnd

Time5tepEndAction



11. Ensure you have clicked on the Cpp_IEEET1DM, and then right click anywhere in the top-right pane,
or on the word “None”. Then, select Insert.

User Defined Models all

B Al
4 [ UserDefinedExciter Mumber of Bus(ID| Model Mame  |Mame_Mominal [Name o
i cpp_IEEET1UDH AL
i |
4 [ UserDefinedGoverm| [ ——— Narie: |De
HH cpp_TGOV1UDM
1 UserDefinedLoadMao g Show Dialog..
4 [ UserDefinedMachine o ] ]
B cpp_GENCLSUD g Display/Column Options...
3 UserDefinedMTDCC ) _ _
Find... Ctrl+F
3 UserDefinedMultTer J ’:’ #h bt L
4 [ UserDefinedStabilize DLL Location |43 #4  Search for Text... =
ocation C:\Us
HH cpp_IEEESTUDN Insert.. L
Model T UserD: IEE
odel Type  UserDe Delete IEE
DLL Functions rs
Mames : Geographic Data View v cfau

12. The Generator Information dialog box should be shown. Here, the built-in IEEET1 exciter model at
Bus 1 will be replaced by an Cpp_IEEETIUDM user defined exciter model. Click Insert.

Generator Information for Current Case el . 3 s
Tad Status
Bus Mumber 1 - % Find By Number ) Open
Bus Mame Busl + | Find By Name (@) Closed
y Energized
=
Eind NO (Offiine)
Area Mame  1(1) (@) YES (Online)
na labels Fuel Type [Unknown vl
Generator MVA Base 500.00 Unit Type [UN {Unknown) "l

| Power and Voltage Control | Costs | OPF I Faults I Owners, Area, etc, I Custom | Stability |
Machine Models | Exdters |Governors I Stabilizers | Qther Models I Step-up Transformer | Terminal and State |

fInsert | [ Delete | GenMvABase 500.0 | show Block Diagram | | Create VCurve |
Type [ Active - IEEET1 - l Active (only one may be active)|  Set to Defaults
Parameters

[PU values shown/entered using device base of 500.0 MYA -

Tr 0.0000 = Te  0.5000 = E2  3.7300 =
Ka 50,0000 = Kf  0.0%00 = SE(EZ)  0.3300 =
Ta  0.0400 = T L4600 = Spdmlt  0.0000 =

Vrmax 1.0000 = Switch 0.0000

Vrmin  -1,0000 = E1l 2,8000 =

4
4

Ke -0.0800 =  SE(E1)  0.0400

? Help I [ Print

[ o OK ] [ Save ] [xCanoel]




13. Here, select Cpp_IEEET1UDM. Click OK.

Model Type E, 23

Select Model from the Below List

- BESEX1
-+ Cpp_IEEET 1UDM
- EMACIT
- ESACLA
- ESAC2A
- ESAC3A
- ESACA
- ESACSA 7
Show Models Supported By
PW Only PTI
[Clera GE

Limit Models by Machine Model

>

14. Now the Cpp_IEEET1UDM user defined exciter model has been inserted at Bus 1, and is ready for
use. The default parameter values have been loaded from the DLL, which can be altered if needed.
For now, leave the values as the defaults, click Save, and then OK.

Machine Models | Exciters |Govemors I Stabilizers | Other Models I Step-up Transformer I Terminal and State |

[ Insert ] [ Delete ] Gen MVA Base  500.0 [ Show Block Diagram ] [Create 'U'CL.IrVE]
Type [ Active - Cpp_IEEET1UDM  w l Active (only one may be active)| Set to Defaults
Parameters

IPU values shownfentered using device base of 500,0 MVA vl

4

Tr 0.0000 Te  0.0600 = E2 37300 =

L3

Ka  50.0000 Kf 0.0900 = SE(EZ) 0.3300 =

-

4

.3

Ta  0.0400 TF 14600 = Spdmlt  0.0000 =

L

Vrmax 1.0000 = Switch 0.0000 =

¥rmin  -1.0000 E1l 2.8000

4

Ke  0.0600 = SEEL)  0.0400

[ W OK ] [ Save ] [ x::anoel] [ ? Hebp ] [ Print

15. The model is now ready for use. This test case already contains a Transient Contingency named
UDM_COMBINED_DEMO, which contains a fault at Bus 7. To execute the simulation, click on the
Run Transient Stability button.



3. Advanced Developers

For developers planning to create DLLs for new models, debugging will need to be done from the IDE in
which the DLL is being built. Similar to instructions in Section 2, developers can point directly to a sub-
folder within a DLL project folder. This will eliminate the need to copy-paste the DLL file to a different
location, and will help with a smoother debugging experience.

The following are the folders of interest in the following programming languages (IDEs)
1. Object Pascal (Embarcadero® Delphi® XE Version 15.0)
~Debug\Win32
2. Visual C++ (Microsoft® Visual Studio 2010)
~\Debug
3. Fortran (Microsoft® Visual Studio 2010 with Silverfrost FTN95 plug-in)
~Debug\Win32

For debugging, the pwrworld.exe process can be attached to the debugger being used. This can also be
done by specifying the location of the pwrworld.exe file (from the installation directory of PowerWorld
Simulator, version 17 or later) as the launch target during the debugging process.

Note: While re-building DLLs during the debugging process, ensure that the attached PowerWorld
Simulator is closed



